پیکربندی سوئیچ شبکه سیسکو برای راه اندازی و استفاده ، کار چندان سختی نیست !

فرض کنید یک سوئیچ شبکه سیسکو ۳۷۵۰ خریداری کرده اید و نیاز دارید که ابتدا یک یوزر روی آن بسازید و بتوانید با تعریف یک IP به آن telnet بزنید . یا مثلا هر پورت سوئیچ سیسکو ۳۷۵۰ را عضو یک VLAN نمائید ، یا یک پورت را جهت اتصال به یک سوئیچ سیسکو دیگر و یا روتر سیسکو ترانک کنید ، یا برای مثال سوئیچ شما از POE پشتیبانی میکند و میخواهید IPPhone یادوربین  یا Wireless Radio را با آن روشن کنید …

در این مقاله سعی داریم که به شکل مقدماتی و برای رفع مقطعی مشکلات دوستان به آموزش سطحی برخی از این کاربرد ها در حد طرح کامند بپردازیم :

برای شروع ابتدا سوئیچ شبکه سیسکو را با کابل کنسول سیسکو به یک کامپیوتر با پورت سریال متصل و با یک برنامه ترمینال مثل Putty به آن متصل شوید .

۱ساخت username و password و ایجاد سطح دسترسی :

ورود به privilageمحیط

switch>enable 

switch#conf t

switch(config)#aaa new-model

switch(config)#username pooyeshnet password 0 qweasdzxc@1234

switch(config)#enable secret qweasdzxc@1234

۲اختصاص دادن یک IP و default gateway به سوئیچ برای دسترسی IP :

switch(config)#int vlan 1 ( کانفیگ وی لن ۱ )

switch(config-if)#ip address 192.168.1.2 255.255.255.0 ( اختصاص آدرس )

switch(config-if)#no shutdown

switch(config-if)#exit

switch#vlan database

switch(vlan)#vlan 1 name Pooyeshnet (ساخت وی لن ۱ )

switch(vlan)#exit

switch#conf t

switch(config)#ip default-gateway 192.168.1.1 ( آدرس روتر )

با این روش که ملاحظه کردید به راحتی میتوانید یک vlan بسازید و به آن IP اختصاص دهید ، توجه کنید که vlan 1 به شکل پیشفرض ساخته شده و تمامی پورت ها عضو vlan 1 هستند .

۳اختصاص هر پورت به vlan خاص :

براس مثال میخواهید چند پورت عضو Vlan خاصی باشند ، ابتدا با روش بالا vlan ها را بسازید ( Vlan database ) ، نیازی هم به اختصاص IP به هر vlan نیست ، سپس ، با روش زیر هر پورت را عضو vlan مورد نظر کنید :

switch(config)#int fastehernet 0/1

switch(config-if)#description “connected to cisco router”

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#exit

switch(config)#int fastethernet 0/2

switch(config-if)#description “web Server”

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 20

switch(config-if)#exit

توجه داشته باشید در هر لحظه میتوانید با دستور زیر تغییرات را ذخیره کنید ، در غیر این صورت بعد از خاموش روشن کردن سوئیچ ، کانفیگی وجود نخواهد داشت !

switch#write

۴کانفیگ پورت سوئیچ سیسکو برای مود ترانک :

ترانک نوعی ارتباط است که حامل vlan هاست ! این ساده ترین نوع توضیح است ! برای مثال شما ۲ سوئیچ شبکه سیسکو دارید و روی هر سوئیچ ۳ عدد vlan به شماره های ۱۰-۲۰-۳۰ ، حال میخواهید nod هایی از هر سوئیچ امکان دسترسی به nod  های سوئیچ دیگر که در همان vlan هستند داشته باشند.

switch-a(config)#interface gigabitethernet 0/1

switch-a(config-if)#description “Trunk to switch B”

switch-a(config-if)#switchport mode trunk

switch-a(config-if)#switchport  trunk allowed vlan all

switch-a(config-if)#do wr

مشابه همین تنظیمات را در سمت دیگر نیز انجام داده و سوئیچ ها را توسط این پورت به هم متصل کنید . به همین سادگی …

۵استفاده از امکان POE :

یکی از قابلیت های سوئیچ های سیسکو ، امکان پشتیبانی از POE یا همان استاندارد ۸۰۲٫۳af که برق را با ولتاژ ۴۸v به نود ارسال کرده و امکان روشن کردن دیوایس هایی که از  POE پشتیبانی میکنند مثل IP Phone – IP Cam – Wireless radio   و … را دارد .

switch(config)#interface fastethernet 0/1

switch(config-if)#power inline auto

switch(config-if)# no shutdown

switch(config-if)#do wr

دستور فوق باعث میشود ، در صورتی که دیوایس متصل شده به سوئیچ سیسکو قابلیت POE را دارا بود ، ولتاژ به آن ارسال شود .

خب چند نکته ، سوئیچ های سیسکو یک Vlan Database دارند که اطلاعات هر Vlan در آن ذخیره و میتوان آنرا توسط VTP  با سایر سوئیچ های سیسکو به اشتراک گذاشت ، برای ایجاد هر Vlan حتما باید آن Vlan در vlan database موجود باشد .

سوئیچ های لایه ۲ سیسکو قابلیت IP Routing نداشته و برای Routing میبایست از یک روتر برای inter vlan routing استفاده کرد .

سوئیچ های سیسکو به صورت پیشفرض به صورت یک سوئیچ معمولی عمل میکنند و تمامی پورت های آنها در حالت فعال و ب صورت پیشفرض عضو vlan 1 هستند ، پس میتوانید از باکس خارج کنید و به برق بزنید و استفاده کنید .

ضمنا می توانید مقاله ۱۰ دستور امنیتی در سوییچ های سیسکو را از اینجا مطالعه نمایید.

 

3 دیدگاه‌ها

  1. با سلام و خسته نباشید من یه سویچ سبسکو مدل sg350خریدم وقتی تمام پورت های شبکه را به سویچوصل میکنم شبکه دارم اما اینترنت ندارم
    ورودی دسترسی به مدم من با رنج 2ِ10 و dmz 2.11 و خروجی از مدم به روتر است از روتر خروجی 1ِ.216 است از روتر هم وصل میکنم به سویچ باز اینترنت ندارم باید چیکار کنم

    • سلام ابتدا چندتا كار انجام بديد.
      1.كابلي كه مستقيم از مودم اومده به سوييچ رو بكشيد و لپتاپتونو بزنيد بهش.ببينيد شبكه و اينترنت ميگيره يا خير
      2.وارد تنظيمات سوييچ بشيد و ببينيد كه آيا تنظيمات خاصي روي اون هست يا خير
      3.ببينيد مودمتون به صورت اتوماتيك IP به كامپيوترها ميده يا خير
      4.اگر مشكلتون حل نشد با شماره هاي شركت تماس بگيريد راهنماييتون كنم.

ارسال یک پاسخ

لطفا دیدگاه خود را وارد کنید!
لطفا نام خود را در اینجا وارد کنید