عبارت VLAN برگرفته از Virtual Local Area Network و یک روش لایه ۲ می باشد.LAN  در واقع یک Broadcast Domain است، ایجاد Virtual LAN نیز یعنی تفکیک یک Broadcast Domain  به دو یا چند Broadcast Domain جدا از هم. پس توسط VLAN شما می توانید شبکه خود را به قسمت های مختلف تقسیم بندی کنید. توجه داشته باشید که حتی با داشتن Subnet های یکسان باز هم می توانید قسمت های مختلفی را در شبکه خود بوسیله Vlan بوجود آورید که هیچگونه ارتباطی با یکدیگر نداشته باشند.

درواقعVirtual LAN  از جمله ابزارهای سوئیچ های مدیریتی است که دسته بندی پورت های سوئیچ و کامپیوتر ها در یک LAN منطقی و مجازی برای کم کردن اثرات سوء پیغام های broadcast یا اهداف امنیتی است. برای جلوگیری از پیام های Broadcast ، جلوگیری از هدر رفتن Bandwidth و امنیت بیشتر، از Vlan استفاده می کنند . برای اینکار پورت های سوئیچ را Vlan بندی می کنند یعنی (سیستم ها در Vlan مربوطه با Broadcast Domain خود قرار می گیرند). می توان بجای استفاده از چند سوئیچ در شبکه از یک سوئیچ با قابلیت Vlaning استفاده نمود و دیوایس های مربوطه را عضو Vlan به صورت مجزا کرد .
Vlan  یکی از راه هایی است که شما با کمک آن میتوانید در شبکه تنظیمات خاصی انجام دهید مانند:

  • کوچک کردن دامنه Broadcast ها
  • ایجاد شبکه های اختصاصی و مجزا در شبکه کلی

برای ایجاد یک vlan در میکروتیک ابتدا در interface می بایست add(+) را بزنید و گزینه vlan را انتخاب کنید، سپس در قسمت port آن interface  هایی که می خواهیدvlan  بشوند را می بایست انتخاب کنید.

–   قرار دادن دستگاه ها در یک ویلن:

روی هر کدام از روترها باید Vlan ست شود.

interface vlan> add name=test vlan-id=200 interface=ether1

وقتی Interfaceویلن ها در حالت Running باشند می توان به آنها IP داد.

Router 1:

ip address> add address=10.10.10.2/24 interface=test

 Router 2:

ip address> add address=10.10.10.1/24 interface=test

حال میتوانند یکدیگر را پینگ کنند.

  • راه اندازی Vlan در میکروتیک به صورت Access و Trunk با استفاده از Bridge

در این مثال ما بجای استفاده از switch از قابلیت Bridge استفاده میکنیم در این حالت مصرف CPU روتر بیشتر است)  این حالت برای روتر های مناسب است که امکان Switch  را ندارند مانند سری  CCR).

گام اول

ابتدا یک bridge میسازیم و Vlan-Filtering را بر روی آن غیرفعال میکنیم تا در حین کار با روتر دسترسی قطع نشود.

/interface bridge
add name=bridge1 vlan-filtering=no

گام دوم

اینترفیس های Ether2,6,7,8 را در قسمتBridge – Port   اضافه میکنیم و برای آنها pvid را مشخص میکنیم تا ترافیک بدون تگ آنها به Vlan مورد نظر آنها اختصاص دهیم.

/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether6 pvid=200
add bridge=bridge1 interface=ether7 pvid=300
add bridge=bridge1 interface=ether8 pvid=400

گام سوم

در این مرحله Bridge Vlan میسازیم و برای آن ها Tagged پورت و Untagged  پورت را مشخص میکنیم

/interface bridge vlan
add bridge=bridge1 tagged=ether2 untagged=ether6 vlan-ids=200
add bridge=bridge1 tagged=ether2 untagged=ether7 vlan-ids=300
add bridge=bridge1 tagged=ether2 untagged=ether8 vlan-ids=400

گام آخر

و در آخر  Vlan-Filtering را فعال میکنیم.

/interface bridge set bridge1 vlan-filtering=yes

  • راه اندازی Vlan در میکروتیک به صورت Access و Trunk با استفاده از Switch

در شکل بالا همان طور که می بینید اینترفیس Ether2 اینترفیس Trunk میباشد (Tagged) و اینترفیس های Ether3,4,5 اینترفیس های Access  هستند (Untagged) . یعنی اینترفیس ۲ ما فریم های تگ شده را دریافت میکند و سپس چیپست قسمت سویچ روتر ما با توجه به تگ آن اینترفیس مربوطه میفرستد.

مرحله اول

مستر پورت (Master Port) را برای تمامی اینترفیس های Access  اینترفیس Trunk قرار میدهیم که در سناریوی ما به صورت زیر خواهد بود:

/interface ethernet
set ether3 master-port=ether2
set ether4 master-port=ether2
set ether5 master-port=ether2

توجه :  این عمل فقط برای اینترفیس های که در یک گروه هستند امکان پذیر است

مرحله دوم

به قسمت Switch à Vlan میرویم و ورودی های زیر را اضافه میکنیم تا امکان جابه جای فریم ها با Vlan ID خاص بین اینترفیس های مورد نظر بوجود آید.

/interface ethernet switch vlan
add ports=ether2,ether3 switch=switch1 vlan-id=200
add ports=ether2,ether4 switch=switch1 vlan-id=300
add ports=ether2,ether5 switch=switch1 vlan-id=400

مرحله آخر

برای اینترفیس های مورد نظر Vlan ID اختصاص میدهیم

/interface ethernet switch port
set ether2 vlan-mode=secure vlan-header=add-if-missing
set ether3 vlan-mode=secure vlan-header=always-strip default-vlan-id=200
set ether4 vlan-mode=secure vlan-header=always-strip default-vlan-id=300
set ether5 vlan-mode=secure vlan-header=always-strip default-vlan-id=400

ارسال یک پاسخ

لطفا دیدگاه خود را وارد کنید!
لطفا نام خود را در اینجا وارد کنید